Music doesn't work correctly

Use this forum to report any bugs or other problems you might discover.

Moderator: Don

Music doesn't work correctly

Postby mac » Sun Sep 02, 2007 12:19 am

The music does not turn off. Even after I delete all the songs from the playlist music still plays. When I add music, it plays at the same time as the music that came with the game, even though I removed the original music from the playlist. The orginal music is overpowered by the new music if I turn up the sound slider to level 10 or 11 (the top two tick marks on the sound level slider) At levels 6-9 the newly added song still plays, but the music original to the game plays too, and at a louder level than the newly added song, even though this original music has been deleted from the list.

Mac OSX 10.4.10
Bliss Version: downloaded a couple days ago.
mac
 
Posts: 17
Joined: Fri Aug 31, 2007 5:57 pm

Postby Don » Sun Sep 02, 2007 9:03 am

Hi,

This is certainly something that I have not heard of before. We don't have a decent manual for the Java version yet, so it may not be obvious that there are two playlists and two music players in the game. The first is the background playlist that runs all the time during the game. The other is the action list that provides music for certain actions. It sounds like somehow they are both running.

In the upper right corner of the sound preferences dialog there are two radio buttons, action and background. Checking one of these causes the appropriate playlist to be displayed. So if, for instance, action is checked, you are seeing (and modifying) the action list as well as setting the volume for that list. It sound like the background list is still playing while you are doing this (or vice versa). I will do some testing to see if I can duplicate this. Could you try looking at the other list and see if this is what is happening.


Thanks,

Don
User avatar
Don
Super Moderator
 
Posts: 1078
Joined: Fri Oct 28, 2005 3:37 pm
Location: Florida

Postby mac » Mon Sep 03, 2007 12:16 am

I had noticed the two different players, the Action and Background.

Today, though, the problem with the original music playing at the same time as the newly added music isn't happening. Maybe I was too tired last night to be trying to figure anything out and I imagined the whole thing. The music will even turn all the way down/off today. Which I prefer to do, and just have iTunes play in the background.

So, either I was hallucinating last night, or there is a bug, perhaps due to my first time fiddling with the music player. My initial attempt to stop the music from playing was to delete the playlists. So at one point I did have no music in the playlists at all, but music still played in the background. Then I added new songs to the playlist, and the original music (if I wasn't hallucinating last night) still played while the new music played.

Although, as I said above, today the music seems to work okay, if a bit clunky. The stop/start button immediately responds visually, but the sound doesn't stop and start at the time of clicking. There's a slight delay in the starting and stopping of the music that varies in duration from click to click of the start/stop button. The music does start or stop within less than a second of clicking the button.
mac
 
Posts: 17
Joined: Fri Aug 31, 2007 5:57 pm

Re: Music doesn't work correctly

Postby dkjr » Mon Jun 01, 2009 1:48 am

My music will not play at all. Using jBliss. I replaced all the music in the player and none of it will play. The sound effects all work but the music will not play in the sound preferences pane or in the game itself.
dkjr
 
Posts: 1
Joined: Mon Jun 01, 2009 1:34 am

Re: Music doesn't work correctly

Postby jwsl » Fri Aug 03, 2012 8:23 pm

I can not get my music to work right either. It loaded up 2 songs fine. I tried to load up 6-8 others and they appear in the Sound and Music Preferences window (like the other 2), but when I highlight the song and push play it is mute. I have tried renaming the songs, taking out commas, brackets, and/or numbers, but nothing seems to work. The first 2 songs work when I highlight them and push play.

They are .mp3 songs, not .mp4. I'm stumped.
jwsl
 
Posts: 1
Joined: Fri Aug 03, 2012 8:16 pm

Re: Music doesn't work correctly

Postby Don » Mon Aug 06, 2012 7:22 am

I am starting to wonder if there are certain types of MP3 that the java player doesn't handle right.

Could you send me one of the songs that won't play via email at supportATgamesforlovingDOTcom.

Don
User avatar
Don
Super Moderator
 
Posts: 1078
Joined: Fri Oct 28, 2005 3:37 pm
Location: Florida


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 2 guests

cron