saving the license key

Use this forum to report any bugs or other problems you might discover.

Moderator: Don

saving the license key

Postby tsarina » Sat Dec 03, 2005 9:11 pm

is it supposed to happen like this? every time i start the game, i have to re-enter the license key. is there any way for the program to save it in case i am somewhere and don't have the key available? or do i need to save the key on my own somewhere? thanks!
tsarina
tsarina
 
Posts: 3
Joined: Sat Dec 03, 2005 9:08 pm

Postby Don » Sun Dec 04, 2005 12:29 pm

tsarina,

You should only ever have to enter the license key once. When you do, it should create a file called Bliss.Board.Lic in the directory where the program is installed (usually c:\program files\games for loving\bliss)

You could look in that directory and see if that file exists. If it does, perhaps you could delete it and try entering your license again, or you could just create a file by that name and use a text editor such as notepad to put your license key in there.

In any case, I don't know why this would be happening. Are you running as a non-administrative user? perhaps there is a permssions issue involved.

Thanks,

Don
User avatar
Don
Super Moderator
 
Posts: 1078
Joined: Fri Oct 28, 2005 3:37 pm
Location: Florida

key problem

Postby logik » Wed Jan 11, 2006 8:59 pm

Hi Don. I'm having the same problem. Every time I run the game it asks for the license key again. I checked the directory and I have the .lic files for both the Bliss game and action editor. When I open them with a notepad it includes the correct license key. I've upgraded to version 1.3 and am still facing the same frustrating problem. Please advise on how I can fix this.
logik
 
Posts: 2
Joined: Wed Jan 11, 2006 8:57 pm

Postby Don » Wed Jan 11, 2006 9:07 pm

I am very sorry to hear about this problem.

I must admit that I have no idea what is causing it, but I am sure we can get to the bottom of it.

Could you tell me the following:

1. What version of Windows and Service Pack are you running?
2. Are you logged in as an administrator or as a limited user?

Could you attach the license files to an email and send them to me at don@gamesforloving.com. I could check them and see if I can see anything wrong with them.

THanks,

Don
don@gamesforloving.com
User avatar
Don
Super Moderator
 
Posts: 1078
Joined: Fri Oct 28, 2005 3:37 pm
Location: Florida

a fix with the cd

Postby tsarina » Wed Jan 11, 2006 9:21 pm

hi, i never was able to make it work with the downloaded version of the program, but once i received the cd, i deleted the downloaded program and reinstalled it from the cd, with the license, and it has worked ever since. it is a great program, we used it the first time on a night away from family during the Christmas holiday, and it was wonderful :-) thanks, and i hope this helps others, even if they have to get the cd...cara
tsarina
 
Posts: 3
Joined: Sat Dec 03, 2005 9:08 pm

Postby Don » Wed Jan 11, 2006 9:29 pm

Tsarina,

Thanks for your input on this, that is good information.

The program on the CD is identical to the one that is downloaded. So this means that one of two things happened.

1. The program was partially corrupted during the download.

or

2. The install somehow didn't work right.

I would guess that either of these would be solved by uninstalling the program, redownloading it, and reinstalling it.

I am going to research further why this migh have happened in the first place though.

Thanks,

Don
User avatar
Don
Super Moderator
 
Posts: 1078
Joined: Fri Oct 28, 2005 3:37 pm
Location: Florida

saving license key

Postby logik » Thu Jan 12, 2006 10:46 am

Hi Don. Thanks for your quick reply. I'm running Windows XP and I am indeed logged in as the administrator (only have one user on the computer). I'm not in front of the computer at the moment, I'll e-mail you the license files. Looking at the last night, they appeared to be plain text wiht just the key in them (when opened by Notepad). I'll also uninstall and re-install the program. Thanks for your help.
logik
 
Posts: 2
Joined: Wed Jan 11, 2006 8:57 pm

PROBLEM SOLVED

Postby Don » Tue Jan 17, 2006 11:27 am

Hi all,

Thanks to logik, we have found the cause of this. The problem is a bug in the way license files are stored. It will be fixed in the next release, but for now there is an easy workaround.

This problem happens when a license key gets wrapped into more than one line in the email process. That key is entered into the license window, which accepts it, but then saves it as it was entered, with the extra carriage returns in the line.

To fix the problem, use notebook to edit the license files, which are located in c:/Program Files/Games for Loving/Bliss. They are called Bliss.Board.lic and Bliss.ActionEditor.lic

When you open them in notebook, you should see something like

XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX

(where X represents digits or letters)

The problem happens if you see

XXXX-XXXX-XXXX-XXXX-XXXX-XXX
X-XXXX-XXXX

When the license key is split across two lines, it is not accepted by the game. Just remove the extra carriage return in Notepad and resave the file and the problem should go away.

Thanks,

Don
User avatar
Don
Super Moderator
 
Posts: 1078
Joined: Fri Oct 28, 2005 3:37 pm
Location: Florida

Postby welshlover » Tue Feb 21, 2006 9:08 pm

On the same subject, I noticed an issue when I installed the game on a new laptop today. I copied the lic key from the email and pasted it in when asked by the game. It appeared as if it wasn't being pasted to I must have repeated the paste a few times. It rejected the lic key but continued.

I then discovered the names were not as I expected, so I edited the lic file in notepad and found four copies of the key. It appears as if its possible to enter longer strings than the key? would this be true?

Could I suggest using the RegExpression classes in .NET framework to validate the keys format and length? Sorry for the technical bug report but it looks like your super game attracts geeks and techies like me :shock:

Keep up the good work, great game!
welshlover
 
Posts: 28
Joined: Mon Feb 13, 2006 4:58 pm
Location: UK

Postby Don » Wed Feb 22, 2006 8:43 am

Welshlover,

Thanks for your input on this. Obviously I need to improve things here. Unfortunately the RE classes aren't going to help too much because the length of the keys varies. Of course the format could be verified, as it is always XXXX-XXXX-XXXX, but the number of actual digits varies from key to key.

Thanks,

Don
User avatar
Don
Super Moderator
 
Posts: 1078
Joined: Fri Oct 28, 2005 3:37 pm
Location: Florida


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 3 guests